A small number of Myriad Cloud stations hosted in the European region are seeing some slow performance

Incident Report for Broadcast Radio

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 11:06 GMT

Update

This issue is now resolved and all stations are running normally. If your station is still experiencing issues, please use the Restart Station option in the Control Panel first and if that doesn't resolve it please raise a ticket via https://help.broadcastradio.com/

The original root cause was with one specific customer deployment which was stuck in an infinite loop, trying to read and write huge amounts of data to Azure storage causing automatic throttling within Azure. This led to silences on a very small subset of stations as the system took significantly longer than expected to load audio files from Azure.

Based on our new understanding of how this throttling is applied, we are working on additional monitoring to detect such deployments and reset or remove them before they cause any impact to other parts of the system.

These changes will be on top of other significant streamlining work that we have already completed and is now actively being beta tested across a selection of test systems prior to a full roll out in the new year.
Posted Nov 21, 2025 - 11:05 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 21, 2025 - 10:10 GMT

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 21, 2025 - 10:09 GMT

Investigating

We are currently seeing a small number of Myriad Cloud stations that are hosted in the Microsoft Azure North Europe region seeing slower performance.

We are currently investigating and will post an update as soon as we have more information
Posted Nov 21, 2025 - 09:55 GMT
This incident affected: Myriad Cloud (Myriad Cloud Playout (Native/Azure based)).