Cloudflare global issues causing slow responses to some web services

Incident Report for Broadcast Radio

Resolved

We have been monitoring the platform for the past two hours since bypassing Cloudflare services. Although Cloudflare continues to experience disruption, Myriad Cloud and Broadcast.Radio Portal have remained up and fully operational.

We would encourage customers experiencing issues loading our to press Shift + F5, or clear browser cache, to ensure you have received the latest updates that remove Cloudflare.
Posted Nov 18, 2025 - 14:24 GMT

Monitoring

Although Cloudflare are reporting signs of recovery, we have temporarily bypassed/removed Cloudflare services from Myriad Anywhere Cloud and the Broadcast.Radio Portal, so any recurrence will not have any impact on these services.
Posted Nov 18, 2025 - 12:36 GMT

Investigating

Cloudflare (pretty much the largest content distribution network host on the planet) is currently having serious issues and this is having a knock effect to thousands of webservices globally. This is not only affecting services hosted via Cloudflare, but also the internet in general as many users and systems are struggling to route around the issues at CF.

This outage has NOT affected our streaming services as these do not use any Cloudflare services.

Myriad Cloud and Myriad Anywhere themselves are NOT affected due to this outage, and all Broadcast Radio systems are running normally, however we do use a small part of Cloudflare to help distribute some parts of our web based services, and you may see some slowdowns when you first open a browser to login to some parts of the Broadcast.Radio or Myriad Anywhere platforms until Cloudflare resolve this issue.

Because of the way our platforms are designed, we are able to switch off our use of CF services just in case of this scenario and we are throwing that switch now, but it will take a few minutes for that to propagate around the internet.

If you DO find yourself seeing slow updates for websites, avoid refreshing the browser and just leave it to finish loading.

As soon as Cloudflare posts an update we'll update here, and we'll publish a Status Page note shortly.
Posted Nov 18, 2025 - 12:29 GMT
This incident affected: Myriad Anywhere Cloud, Broadcast Radio Live (Myriad Anywhere Cloud), Myriad Cloud (Myriad Cloud (Native/Azure based) Management), and Streaming, Web hosting, Apps and smart speaker skills (Broadcast.Radio websites).