Broadcast.Radio websites and admin control panel access is slow or down for some users

Incident Report for Broadcast Radio

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 15:48 BST

Monitoring

Database recovery is continuing in the background. We have re-enabled Now Playing updates.
Posted Mar 31, 2026 - 14:59 BST

Identified

We have applied a temporary mitigation to restore full functionality when signing into Myriad and BR Live, fixing the issue where a small percentage of sign-in requests were timing out. We are continuing recovery work on the main database cluster. We have temporarily suspended Now Playing updates whilst this work completes.
Posted Mar 31, 2026 - 13:21 BST

Investigating

We are currently seeing an extraordinarily high number of invalid security requests hitting the broadcast.radio platform which affecting the performance of the administration pages which is also having a knock on effect that is causing some pages to load slowly.

This may also affect some users if they are using Broadcast.Radio integrated logins to login to Myriad Anywhere.

Engineers are currently working to mitigate this externally caused issue and we will post an update in due course.
Posted Mar 31, 2026 - 12:59 BST
This incident affected: Myriad Anywhere Cloud, Broadcast Radio Live (Myriad Anywhere Cloud, Broadcast Radio Live) and Streaming, Web hosting, Apps and smart speaker skills (Broadcast.Radio websites).