UK Office telephone connection outage
Incident Report for Broadcast Radio
Resolved
This incident has been resolved.
Posted Aug 25, 2023 - 13:09 BST
Monitoring
Our telephony provider have now fixed the fault with the telephone circuit to our local UK number. Customers may now call 01482 350700 as usual for telephone support and product/sales queries.
Posted Aug 25, 2023 - 10:41 BST
Update
We are continuing to wait for an update from our uk telephony provider, so we have arranged a temporary number should you need to reach the Broadcast Radio UK offices by phone.

The temporary number is (+44) (0)1904 938800 and can be used during the day but also to contact our out-of-hours broadcast emergency engineer service.

You can also continue to reach us via our Irish number ( +353 818 663 421 ) and the Broadcast Radio USA office is NOT affected by this uk specific issue.

As always, you can also reach us via support@broadcastradio.com or open a ticket via https://tickets.broadcastradio.com

For avoidance of doubt, all Broadcast Radio services are fully functional.
Posted Aug 24, 2023 - 19:47 BST
Update
We are waiting for our telephony provider to complete their investigation. As usual, outside of our office hours, only emergency out-of-hours telephone support is available.

Due to the UK local number outage, customers will need to telephone our Irish number (+353 818 66 34 21), following the usual menu options to access the chargeable out of hours service. We apologise for any inconvenience this may cause.
Posted Aug 24, 2023 - 18:03 BST
Identified
Our telephony provider is currently experiencing connectivity issues. This is affecting our ability to receive telephone support calls on our local UK number. Our international telephone numbers (including our Ireland number) are working and we recommend, where possible, customers telephone our Irish number (+353 818 66 34 21).

If you cannot dial internationally from the UK, please email support@broadcastradio.com. If you are off-air and require urgent support, please include "OFF AIR" in the email subject, so our support engineers can prioritise your ticket.

For avoidance of doubt, all Broadcast Radio services are fully functional.
Posted Aug 24, 2023 - 16:54 BST
This incident affected: Account management, Technical Support and other online services (Contacting Broadcast Radio).