Some Myriad Cloud stations hosted in the European region are seeing some slow performance or disconnections

Incident Report for Broadcast Radio

Resolved

This incident is now resolved and we will publish a full post mortem in the next few days once we have carried out a full analysis.
Posted Nov 25, 2025 - 17:08 GMT

Update

Correction to the url for the help portal - apologies, we added the wrong url!

"All infrastructure has now been updated and all affected stations have fully restarted. If you are still having any issues, please restart your station from the Broadcast.Radio portal, and if you are still seeing any problems after that please contact us via https://help.broadcastradio.com"
Posted Nov 25, 2025 - 15:28 GMT

Monitoring

All infrastructure has now been updated and all affected stations have fully restarted. If you are still having any issues, please restart your station from the Broadcast.Radio portal, and if you are still seeing any problems after that please contact us via https://help.broadcastradio.com

We will be monitoring closely over the next few hours.

Again, we're very sorry about this second outage since Friday, and thank you again for your patience, and we'll publish a post-mortem over the coming days once we have fully investigated whats happened.
Posted Nov 25, 2025 - 15:24 GMT

Update

The updated Azure software has rolled out across 80% of the platform and stations have been coming back online over the last 30 minutes. We are continuing to roll out the update to all other host systems and are working to bring other stations back on line as fast possible.

We're very sorry about this outage and will be working with our upstream partners including Microsoft and it's partners to understand how we can prevent issues within external code from affected Myriad Cloud like this from occurring again.

We will also be looking at how we can alter how we better engineer the underlying platform infrastructure in future so that if a scenario like this ever happens again we can better isolate and move affected stations more swiftly to unaffected infrastructure.

We'll post more information as soon as we have it.
Posted Nov 25, 2025 - 14:34 GMT

Identified

The Microsoft Azure control system that manages the actual physical compute stack has a memory leak within it's control software that is causing our host platform to force restarts to attempt to mitigate the memory issue.

We are urgently rolling out a fix from Microsoft to the affected nodes and will post an update as soon as we have more details.
Posted Nov 25, 2025 - 13:07 GMT

Investigating

We are currently investigating this issue.
Posted Nov 25, 2025 - 12:57 GMT
This incident affected: Myriad Cloud (Myriad Cloud Playout (Native/Azure based)).